Jump to content

Fly the Maddog X - P3D v5.3 HF2 compatibility


Stefano
 Share

Recommended Posts

Hello captains,

I'd like to inform you that latest Maddog X version for P3D v5 (2.1b827) is fully compatible with the v5.3 hotfix 2 (5.3.17.28160): no further actions required!

Blue skies!

Link to comment
Share on other sites

 Share

×
×
  • Create New...

Important Information

Privacy Policy | Terms of Use